[記錄]Visual Studio 2107 不支援 .NET Core 2.2 問題

  • 2289
  • 0

目前的 .NET SDK 不支援以 .NET Core 2.2 作為目標。請以 .NET Core 2.1 或更低版本作為目標

在 2019-02-12 以後,到官網下載 .NET Core 2.2 SDK,安裝後 VS 2017 可能會在建置新 .NET Core 專案時,發生不支援 .NET Core 2.2 的錯誤

因為 VS 2017 對 .NET Core 2.2 只支援到 2.2.1x 而最新穩定版已經到 2.2.2 以上,安裝 2.2.1x 並重啟 VS 即可。

下載頁面

卡在 VS 2019 釋出的這個時間點,是不是微軟在提醒大家該升級一下了呢?

參考

https://developercommunity.visualstudio.com/content/problem/470616/the-current-net-sdk-does-not-support-targeting-net-5.html